ATS Slowness

Incident Report for ICIMS

Resolved

Our monitoring indicates that ATS performance has returned to normal.

If you are continuing to experience slowness or errors when navigating the system, please open a support case.
Posted Apr 06, 2026 - 18:18 EDT

Monitoring

Our monitoring indicates that ATS performance has returned to normal.

If you are continuing to experience slowness or errors when navigating the system, please open a support case.
Posted Apr 06, 2026 - 17:41 EDT

Investigating

iCIMS is investigating reported slowness within the ATS as a top priority. Updates will be provided as they become available.
Posted Apr 06, 2026 - 15:35 EDT
This incident affected: Applicant Tracking System (ATS).