Possible issue with Career Sites

Incident Report for ICIMS

Resolved

This incident has been resolved.
Posted May 29, 2026 - 10:46 EDT

Monitoring

Career Sites are now operating normally. iCIMS will continue to monitor as a top priority.
Posted May 28, 2026 - 15:48 EDT

Investigating

iCIMS is investigating an issue impacting a subset of Career Sites. Some pages may fail to load content, including the jobs page. We are investigating this as a top priority.
Posted May 28, 2026 - 14:48 EDT

Monitoring

Career Sites are now operating normally. iCIMS will continue to monitor as a top priority.
Posted May 27, 2026 - 17:34 EDT

Investigating

iCIMS is investigating an issue impacting a subset of Career Sites. Some pages may fail to load content, including the jobs page. We are investigating this as a top priority.
Posted May 27, 2026 - 17:04 EDT
This incident affected: Career Sites.