Potential issue with EU Career Sites

Incident Report for ICIMS

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 14:03 EDT

Monitoring

EU Career Sites are now operating normally. iCIMS will continue to monitor as a top priority.
Posted Aug 03, 2026 - 07:57 EDT

Investigating

iCIMS is currently investigating an issue that is prevent some EU Career Sites from properly loading job data.
Posted Aug 03, 2026 - 05:50 EDT
This incident affected: Career Sites.