The issue has been identified and resolved as of approximately 4 PM ET on 7-April. Thank you for your patience.
Posted Apr 08, 2026 - 12:26 EDT
Update
iCIMS has added additional resources to address the reported slowness within the ATS, and we are continuing to see improvement in performance. Our teams remain actively engaged and will continue to monitor the environment closely to ensure stability. We will provide further updates as more information becomes available. We appreciate your patience.
Posted Apr 07, 2026 - 16:12 EDT
Update
iCIMS is continuing to investigate the reported slowness within the ATS as a top priority. Our teams are actively working to identify the root cause and restore optimal performance. We will provide updates as more information becomes available. We appreciate your patience.
Posted Apr 07, 2026 - 12:32 EDT
Investigating
iCIMS is investigating reported slowness within the ATS as a top priority. Updates will be provided as they become available.
Posted Apr 07, 2026 - 11:06 EDT
This incident affected: Applicant Tracking System (ATS).