Blank Page on Login

Incident Report for ICIMS

Resolved

The issue has been identified and resolved.
Posted Apr 09, 2026 - 09:25 EDT

Investigating

Multiple customers are reporting receiving a blank page upon login to the ATS. We are investigating this with urgency. We will provide further updates as more information becomes available. We appreciate your patience.
Posted Apr 09, 2026 - 09:17 EDT
This incident affected: Applicant Tracking System (ATS).