HCM Integration Errors

Incident Report for ICIMS

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 17:24 EDT

Monitoring

We are aware that a third‑party HCM vendor is currently experiencing connectivity issues that may impact integrations with our platform. They are actively working the issue at this time. Customers may encounter 503 (Service Unavailable) error or other error messages consistently upon retrying when affected.

Our teams are actively monitoring the situation. This notice will be removed once the external issue is resolved and connectivity is fully restored.
Posted Apr 02, 2026 - 17:05 EDT
This incident affected: Applicant Tracking System (ATS).