Applicant Tracking System - Degraded Performance
Incident Report for iCIMS
Resolved
This incident has been resolved.
Posted Jan 07, 2025 - 14:02 EST
Update
We are continuing to investigate this issue.
Posted Jan 07, 2025 - 14:02 EST
Investigating
iCIMS is experiencing some degraded performance with the ATS platform. Our team is currently working to restore normal performance levels. Some ATS users may be affected. Next update will be just after the top of each hour if not resolved sooner. We thank you for your patience.
Posted Jan 07, 2025 - 12:21 EST
This incident affected: Applicant Tracking System (ATS).